Error when creating an IPC from within another IPC

Version 6

    Verified Product Versions

    LANDESK Service Desk 7.8.xLANDESK Service Desk 2016.xLANDESK Asset Central 2016.xLANDESK Asset Central 2017.xLANDESK Service Desk 2017.x

    Problem

    When trying to create an Incident, Problem or Change (IPC) from within a different IPC you get a message similar to the one below.

     

    Attempt to invoke business function Addxxx on a yyyManagement.yyy lifecycle object at the wrong status zzz

     

    error.png

     

    Cause

    The reason this error occurs is that the action to add xxx to yyy must be available to both objects at the status they are currently at.  So, if you want to be able to add Incidents to Changes at any status you must ensure that the 'Add Change' action is available as at least an optional action on every status of every Incident process you have.

     

    Solution

    STEP 1:  Identify the process and status that the item you're trying to add is using

    Open the item that you want to add and at the top of the tree it will tell you which process the item is currently following.  In brackets after the process name is the current status too.

     

    STEP 2: Add the required action at the status to the appropriate process

    a. In Process Designer, edit the process that the item is running under.  In order to do this you will need to deactivate it, if it is the default you will need to set another process as the default before you can deactivate it.
    b. On the process diagram, locate and click on the status that the item is currently at.
    c. On the Properties panel, click the ellipse (...) button on the 'Optional Action Instances' property.
    d. Select Addxxx from the list of Available Action Instances and add it to the list of Selected Action Instances.
    Step 3: Test it out!

    Ensure that the process has been reactivated then try to add the item again.

     

    Note: Changes to Processes should not be carried out while the system is in use, ensure a full-restorable backup is available before taking the system off-line and making the required changes.  Where possible, apply and thoroughly test on a development system before applying to the live environment.

     

    Environment

    Service Desk all versions