I've created a knowledge article but I can't see it or search on it - why?

Version 3

    Problem:

     

    "I have created a new knowledge article but when I try searching knowledge to find this article it is not shown in the knowledge results?"

     

    Causes and Solutions:

    Here are some of the common causes and how to address them:

     

    Wait a minute!

    The default poll time for the Knowledge Builder is 60 seconds.  In versions prior to 7.3.2 the Verity builder was the Knowledge Builder Service and the poll period could be changed to longer than 1 minute in the Knowledge Management Administration - Knowledge Settings - Verity Settings tab.  From version 7.3.2 the building is done by the Background Processing Service and will be every 60 seconds.

     

    Search Type

    If you are using background searching (this is when you are in an IPC form and an automatic search of text in the form happens) to locate the article we would recommend trying a test to find the article in the Knowledge Management Search component (where you are asked to enter in the keywords manually to search on) instead.  Using Knowledge Management Search, if you have access to this, allows you to govern the exact string that the knowledge index is searched for and it also bypasses the relevance settings in your system (see below about relevance settings).

     

    Approval status

    The article needs to be at an Approved status for it to be built into the knowledge search.  If it isn't then a person with the correct privilege needs to edit the article to move it into the approved status.  If you later change to an approved status it will be built into the knowledge index when the next knowledge build happens.  However if you edit the text in an article after it is approved (if you have the correct privilege to) you can force it to be built into the knowledge build immediately.

     

    Knowledge Domains

    If you use Active Knowledge rather than Core Knowledge there is functionality to separate different types of knowledge for different users.  You can do this by allocating a knowledge domain to an article and then allocating groups the ability to view these.  Once you start using knowledge domains you will immediately see articles are not shown in search results if they have a domain allocated but the group you are in hasn't been given the ability to search that domain.  This is true even of the SA user and Administrator group.  See this article for more information:

    http://community.landesk.com/support/docs/DOC-3562

     

    Relevance Settings

    If you are searching using background search (this is when you are in an IPC form and an automatic search of text in the form happens) then there are some settings in Knowledge Management Administration which will have an effect on the results.  If you go into Knowledge Management Administration - Knowledge Settings - Background Searching tab we would recommend switching the relevance down to 0% temporarily whilst troubleshooting.

     

    Problems building

    Check that your knowledge indexing / building is happening ok.  The easiest way to check this is to go into Knowledge Management Administration - Knowledge Settings - Queue Entries.  Check the status of any queue entries showing here. 

     

    NOTE: Certain types of queue entry will be removed once they are processed successfully so not seeing much in the queue entry list is not necessarily a bad sign.  There is some more information about the Queue Entries in this article: http://community.landesk.com/support/docs/DOC-16969

     

    Expiry date

    Check that the article's expiry date has not passed.

     

    The attribute that you are searching on is not set to knowledgeable

    You need to tell the knowledge builder which attributes you would like to be included in the knowledge index.  If you type text into an attribute that you haven't told the builder to include in the knowledge index then searching on this text will not return any results.  You do this by setting the Search Type on the required attribute to IsNaturalLanguage.  For more information on this please see the Knowledge Management manual (called Active Knowledge on versions before 7.3).

     

    NOTE: If the attribute you are searching on has been set to knowledgeable but the builder doesn't seem to have picked this up then you can force a Metadata Refresh which should correct this.  Please see this article on how to do this: http://community.landesk.com/support/docs/DOC-17225