Configuration Item objects appear soft deleted but actually hard delete

Version 5

    Verified Product Versions

    LANDESK Service Desk 7.6

    Environment:

    Service Desk - All Versions

     

     

    Problem:

    Prior to Service Desk 7.3.1 all Configuration Items had the property in Object Designer for Deletion Type as Soft Deletion but in practice hard deleted.  This was Problem 3968 and was fixed in 7.3.1 so that Configuration Item objects created actually do properly inherit the soft deletion property.  Unfortunately, Configuration Item objects created prior to an upgrade to 7.3.1 (including the ones in the out-of-the-box database) still exhibit hard-deletion properties.

    This means that even versions released today that still include a Configuration Item that has been in place since before 7.3.1 will have this issue.

     

     

    Cause:

    The changes made in 7.3.1 did not retro-actively fix existing Configuration Item objects

     

     

    Solution:

    The existing Configuration Items need a small change to their metadata in the database to start soft-deleting properly, this can be done with the script below.  Please test this script on an off-line copy of the database before applying to live and take a full, restorable back-up of the the database before applying to live.

     

    SQL Server:

    update md_class_type set md_deletion_type = 1 
         where md_defined_by = 2
         and md_supertype_guid = '159677C0-A2D5-45AB-B69A-1DCE7F3B93CB'
    
    Oracle:
    update md_class_type set md_deletion_type = 1
         where md_defined_by = 2
         and md_supertype_guid = 'C0779615D5A2AB45B69A1DCE7F3B93CB';
    This is logged as Problem 5624. If you are experiencing this issue, please log this with your support provider referencing problem 5624.