Making window available to WebAccess errors with: "Could not resolve reference from attribute filter selector..."

Version 5

    Verified Product Versions

    LANDESK Service Desk 7.8.xLANDESK Service Desk 2016.xLANDESK Asset Central 2016.x

    Environment:

    Service Desk - 7.4 and newer

     

    Review Date:

    27.10.2014

     

    Problem:

    When making a window available to Web Access in Window Manager you will get error message:

     

    Error:

    "Could not resolve reference from attribute filter selector <<GUID>> to related query template. This Query template is for the class type Incident, expected process."

     

    Querytemplateerror.jpg

     

     

    Cause:

    When you make a window available for Web Access, all settings for the window will be transferred over to the Web Access window. In Console, the "is 'auto end user customer company' select?" setting is available for all Objects. For Web Access the "is 'auto end user customer company' select?" setting is only available on the Incident Module.

    Service Desk will always try to transfer this setting over to Web Access, but for any Object other than Incident, it won't be able to set this, and so, this error message will show.

     

    Solution:

    When working on a none Incident window, you will need to set the "is 'auto end user customer company' select?" to FALSE at all time on the "Raise User", "Customer" and "Company" attributes, when making the window available for Web Access.

    If you want the same feature still available on your Web Access window, then you will need to manually create this as a filter in Object Designer on the relevant Object and set this to be used in Web Access.

     

    This is a known issue and have been given problem number 5110. If you are experiencing this issue, please log this with your support provider referencing problem 5110.