Starting the Background Processing service causes SQL timeout / deadlock errors for users

Version 2

    Problem

    You start the Background Processing service and now all users are suffering from timeout errors when trying to log in or use an existing Console session.  They may also see dead lock errors.

     

    Cause

    This can occur if a Scheduled Action is running at the time and snapshot isolation is not enabled on the database.

     

    Solution

    Enable snapshot isolation on the database as per the following document: Reducing deadlock errors by enabling Snapshot Isolation in SQL Server.

     

    This is enabled by default on any database shipped with 7.4 or greater but can affect databases on these versions that have upgraded from earlier versions as well as databases still on earlier versions.