Installation problems with XML import error message "Error configuring software store client. Could not add DeliveryMethod" or 'MP_Addon_Groups' does not exist.

Version 8

    Verified Product Versions

    LANDESK Management Suite 9.5

    Under DataAnalytics 9.5 the error message changes to lots of errors when trying to import various xml files that the object 'MP_Addon_Groups' does not exist. The cause and the solution however are the same as with Managed Planet 9.05 and greater.

     

    Description

    During the Database config step of the Data Analytics installation an error messages may pop up indicating that an XML file cannot be imported. The screenshot looks like this:

    Installation_failure.png

    Cause

    Due to some interactions with Management Suite during the install, the O/S must be switched to US English during the install process for the core only.  When the install is complete, it can be switched back.

    See this link for description: http://www.managedplanet.com/news/2012/4/29/landesk-analytics-formerly-known-as-managed-planet-extension.html

    Solution

    To get Data Analytics installed please try the following steps;

    1) Set the localization of your core to American English

      1. To change the settings on Windows Server 2008, go into Region and Language settings.  On the Formats tab change the format to English (United States) and on the Administrative tab click the Change System Locale.  Then set the Current System Locale to English (United States)

    2) Search for a xml called enutranslations.xml in "C:\Program Files (x86)\LANDesk\ManagementSuite"

    3) Copy enutranslations.xml and rename the copy into engtranslations.xml. Make sure both files are in the directory "C:\Program Files (x86)\LANDesk\ManagementSuite"

    4) Re-install Data Analytics