Preferred Server is not being used because of empty preferredServer.dat

Version 3

    Verified Product Versions

    Endpoint Manager 9.5Endpoint Manager 9.6Endpoint Manager 2016.x

    Description

     

    Despite a working configuration of a preferred server, this server isn’t being used by the agents during deployment tasks. A check of the local preferredServer.dat showed that this file is empty.

     

    You may see “LDRedirectFilePathEx: serverList is empty” within an XTrace log of the lddwnld (see http://community.landesk.com/support/docs/DOC-1623)

     

    Cause

    The Agent tests all preferred server if they are reachable via PING. Should they not be pingable the agent will ignore this servers and write them into his local preferredServer.dat

     

    Solution

    Enable ICMP within your network.