Basic troubleshooting guide for Data Analytics - Web import rules

Version 8

    Verified Product Versions

    LANDESK Management Suite 9.5LANDESK Management Suite 9.6LANDESK Management Suite 2016.x

    Issue:

    Web Forms are not inserting information, or insert the wrong information to the Inventory of the devices.

     

    General explanation:

    Landesk Data Analytics > Data Translation Services contain several rules, which can populate / create various fields in the inventory of the managed devices. This will focus on the rule DTS > HP\Compaq Warranty > HP\Compaq Warranty as an example.

    The purpose of this rule is to gather warranty related information from the Dell website, then insert this information to the inventory of the client under "Comupter" > "Warranties" > "Warranty"

    This is not meant to be a complete explanation related to web import rules.

    For this please refer to the help site of Landesk Data Analytics:

    http://help.landesk.com/Topic/Index/ENU/LDDA/9.5/DTS_Main

     

     

    Trouble shooting steps:

     

    Step 1

    Always check, if you are using the most up-to-date version LDDA. The web import rules are regulary revised and updated according to the changes made on the web sites we gather information from.

    You can download the latest LDDA version from the Product Download section of LAndesk Commuinty

    http://community.landesk.com/support/community/product_downloads

     

    Step 2

    Create a copy of the problematic rule by right clicking it and selecting copy, as it could be difficult to restore a rule to its original form after it has been modified.

     

    Step 3

    Double click the COPY of the rule to start to investigating. The first dialog lets you select where the the collected information should be stored.

    If you select "Management Suite" - Computer Data, the information collected will be inserted into the LANDesk Inventory of the devices the rule applies to.

    If you select "Asset Control", the information collected will be inserted into the Asset Control module of LDDA, which is practically a separate client database in LDDA. Selecting this option will NOT update the LANDesk Inventory of the devices.

    After we have confirmed that the collected information will be saved to the correct database location,  click next.

     

    LDDA95-2013-02-28-10-39-14.PNG

     

    Step 4

     

    In the next dialog, we can set the URL of the website, from which we wish to collect information and configure the how we want to connect to it.

    It's good to test if we can access the URL from an Internet Explorer window using the same connection settings. After we have confirmed that the URL can be opened without problems, click next.

     

    LDDA95-2013-02-28-10-39-14.PNG

     

    Step 5

     

    In the next dialog, we will concentrate on 2 fields: "Field Name " and "Attribute"

     

    LDDA95-2013-02-28-10-39-14.PNG

     

    "Attribute" tells LDDA the Inventory information from the device to use in the web site. In our case it is "Computer" > "System" > "Serial Number", which has the value "5CB2210TG6".

     

    LDDA95-2013-02-28-10-39-14.PNG

     

    "Field name" indicates the name of the web form field we will use to insert the information that we got from the Inventory of the device.

    A first check would be to comfirm in the source code of the page that we are accessing to verify this field name exists.

     

    This is an example using Firefox. After clicking Options > Web Developer > Page Sorce, the source code of the page will be displayed.

    In our case the source code part that contains the field name, "rows[0].item.serialNumber" will look like:

     

    LDDA95-2013-02-28-10-39-14.PNG

     

    Most of the problems encountered will be caused by any of the following:

     

    Cause 1:

    The attribute set up in the web form contains no data or the wrong data

     

    Solution 1:

    Configure a different attribute that contains the correct information.

    To do this, select the line that contain the wrong attribute name, then click edit and select the correct attribute, then click OK

     

    Cause 2:

    The fields name has been changed on the website since the lastest release of LDDA.

     

    Solution 2:

    The next LDDA version will reflect the change, but as a temporary workaround you could adjust the rule to the new field name.

    A useful tool can be found using Firefox to identify the new field name.

    Select Options > Web Developer > Inspect and point to the field you would like to use. It will tell you the name, which can be used in the source code to find the entry you need to enter in LDDA

     

    LDDA95-2013-02-28-10-39-14.PNG

     

    Step 6

     

    After checking the settings in step 5 there is one more item to review where you can specify if dates should be treated in US format or not. If you have problems related to the date format, you might want to disable the option "Treat dates as US format".

     

    Remarks:

    There are other type of web import rules that connect directly to the API of the given provider. In these cases you will not configure the web site related settings, but the inventory arrtibute part of this guide still applies.