AMC: Could not import license. Database corruption on MS SQL / PostgreSQL

Version 3

    Verified Product Versions

    Avalanche 5.3Avalanche 5.0

    Environment:

    Avalanche Mobility Center (AMC)  5.0 and above

    Databases: MSSQL Server 2005, 2008, 2012, MS SQL 2008, 2012 OR PostgreSQL 8.3 and above

    Problem:

    When activating license in AMC, you get an error " Could not import license. License data in database corrupted.Please contact Wavelink Technical Support".

     

    Solution:

    Enter the following  MS SQL clean license script.

    delete from product_license;
    delete from protected_data where protected_key = "installationDigest;"
    

     

    For PostgreSQL:

     

    DELETE from product_license
    DELETE from protected_data WHERE protected_key = ’installationDigest’