Status HTTP 500 Error in Web Console / I can't run reports / reports don't work (5.3.1 Web Console Patch)

Version 18

    Verified Product Versions

    Avalanche 5.3Avalanche SE 5.3

    Status HTTP 500 Error in Web Console / I can't run reports / reports don't work (5.3.1 Web Console Patch for Postgres Only)

     

    Environment:

    Avalanche Mobility Center 5.3.x

    MSSQL DB / Postgres / Oracle installs

     

    Problems/Issues/Symptoms:

    • Reporting doesn't work in the web console
    • I am able to do some reports but on others I am receiving HTTP Status 500 Errors
    • In the web console when I go to Tools and Settings, I receive an HTTP Status 500 Error
    • I can create reports in the web console, but they do not run.

    7.jpg

    Cause:


    The AvalancheWeb folder that your AMC/ASE server is currently implementing does not contain the needed patches that allow full functionality.

     

    Solution:

     

    Technical Support will send you a .war file. Using the .war file, a new AvalancheWeb folder will be created. This folder will contained the needed patches to correct your Web Console issue (in most cases)

     

    1. Stop the Apache Tomcat for Wavelink service
      1.png
    2. Open your file explorer
    3. Navigate to C:\Progam Files (x86)\Wavelink\AvalancheMC\WebUtilities\Tomcat\webapps
      2.png
    4. Rename the AvalancheWeb folder to OLDAvalancheWeb
      3.png
    5. Rename the AvalancheWeb.war file to OLDAvalancheWeb.old

      4.png


      IMPORTANT: FOLLOW STEP 6 & 7 Especially FOR SQL SERVER

    6. Remove OLDAvalancheWeb from the webapps folder and place it on the desktop
    7. Remove OLDAvalancheWeb.old from the webapps folder and place it on the desktop
      5.png
    8. Please contact Wavelink Technical Support for the most recent AvalancheWeb.war file.
    9. Place this new AvalancheWeb file in the C:\Progam Files (x86)\Wavelink\AvalancheMC\WebUtilities\Tomcat\webapps folder.
    10. Start the Apache Tomcat for Wavelink service
    11. Wait for 10 minutes using the Web Console
    12. Log into the web console and verify that the problem was fixed

     

    If you are using SQL DB then you will need to Copy the WEB-INF folder from the OLDAvalancheWeb folder into the newly created Avalanche Web Folder