Importing Queries from different versions of LDMS (Unsupported)

Version 9

    Verified Product Versions

    Endpoint Manager 9.5Endpoint Manager 9.6Endpoint Manager 2016.x

    ***Please note: While this may be effective for you in a particular situation with a particular exported query, please note this is not and cannot be supported by LANDESK. In addition please be aware that this workaround does not work 100% of the time. There are other factors that may contribute to the query not working, such as the data being in a different place in the database between version.

     

    Environment:

    8.8x Probable
    9.0xConfirmed
    9.5xConfirmed

       

    Problem:

    When you try to import a query from a different version of LDMS than what you are currently in, you will recieve the following error:

     

    Items were rejected because of a version mismatch error.  The first 3 numbers in this assembly version (9.50.0.0) do not match the items' (9.0.3.47).

    Failed to import: query.ldms

    Failed

     

    Cause:

    When you export a query, the LANDESK console embeds the version number of the console in the query.

     

    Solution/ Workaround:

    Open the exported .LDMS file in a text editor, and look for lines containing a string similar to the following:

    <AssemblyVer>9.xx.xx.xxx</AssemblyVer>

    Change all instances of the version number to your console version number.

    Examples:

      • 9.0 sp3/4    9.0.3.47
      • 9.5              9.50.0.0

    Note**: You can find these version numbers in your "Help > About LANDESK > More info" menu in the console.