Archive to Asset Control fails with "All link attributes are blank for source device."

Version 5

    Verified Product Versions

    LANDESK Management Suite 9.6

    Environment:

    This issue can occur in LDMS 9.5 \ LANDesk Data Analytics 9.5 environments.

     

     

    Problem:

    When running the "Archive to Asset Control" option from the right click menu for device(s) in the Core Console, the job will start then fail with an "All link attributes are blank for source device." error as seen in the diagram below:

    Capture.JPG

    The log file that shows this error is found in the ManagementSuite\MP_Log directory and will have a name like:

    Archive Computers to Asset Control-xxxxxxxxxxxxx.log, with the x's showing date information.

     

     

    Cause:

    This can happen when un-modeled Serial Number data is present in the database. This un-modeled data causes the archive to fail.

     

     

    Solution/ Workaround:

    The un-modeled serial number data needs to be removed from the database. This is done using the DBRepair tool. Instructions for this tool are found here: Database Repair Utility (DBRepair.exe download)

     

    The un-modeled data that needs to be removed for this issue is found under Computer > System > Serial Number as shown below with the DBRepair tool:

    metadata.JPG

    Select "Clean" to remove the Serial Number entry then restart the Inventory Server Service on the Core.

    Once DBRepair is done, run the Data Translation Services > Calculate Data > All Rules > Computer.Barcode rule.

    Using these steps will correct the "Archive to Asset Control" procedure against device(s) on the Core Console.