The core server you are connecting to does not appear to have a valid license

Version 11

    Verified Product Versions

    LANDESK Management Suite 9.5LANDESK Management Suite 9.6LANDESK Management Suite 2016.x

    Issue

     

    After upgrading a core server to a newer major release (e.g. 9.6 to 2016 or 2016 to 2016.3s), you may face issues with licensing and subscriptions.

     

    • Starting the Management Console, you receive the message "The core server you are connecting to does not appear to have a valid license."
    • You are unable to activate the core once you upgraded / installed the new version
    • Your core is not downloading patches any more (missing patch manager subscription)
    • Your Management Console does not contain all the features it used to have

     

    Cause

     

    This happens when your license account contains the license and the subscriptions for the version you are upgrading from, but not for the following release.

    It can also happens when you renew a subscription and your license contains only the latest version of the LANDesk Management Suite product, not the one you are running, if you don't have a Core Server running the latest release.

     

    Resolution

     

    1. Before starting an upgrade to a new major release, check your current license and subscriptions from your current core server, going to:

    Start > All programs > LANDesk > Core Server Activation.

    core_activation.jpg

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    2. Verify that all the products, licenses and subscriptions are present and not expired for the release you are planning to upgrade to clicking on the Licenses button:

    license_check.jpg

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    3. If you notice that some of the licenses and subscription are not present for the version you are planning to upgrade to, ask the support team to check your account and adjust the versioning of your LANDesk products, starting from the http://support.landesk.com page.

     

    If you are using an older version

     

    In some cases, you might want to install a version which is not the recent major release.
    For instance, you might want to install a 9.0 core while at the moment of writing the most recent release is the 9.5SP1.
    It is possible to face the same problem as above if your licenses and subscriptions are valid only for the 9.5 version.
    The procedure to follow is the same in any case. If you find out you are missing a license or a subscription for the version you are going to install, ask the support team to check your account and add the versions you need.