MC9190 battery swap (battery removal) causes scanner to stop working during Telnet session

Version 4

    Verified Product Versions

    Wavelink Terminal Emulation 7.0

    Environment:

     

    • MC9190 (MC9100, MC9190-G, etc) running Windows Mobile (WM) 6.5 or Windows Embedded (CE) 6.0
    • Lorax Scanner

     

    Issue/Problem:

    • Scanner does not work after taking out the battery and replacing it with a new one
    • Scanner stops working after removing and replacing battery during a telnet session

     

    Symptoms:

    • Red LED light on the keypad shows that the scanner is being pressed
    • Laser stops working after the battery is replaced

     

    Cause:

    This is a known issue from Motorola and they have a patch for it.

     

    Resolution:

    Here are two Motorola support articles regarding this issue:

     

    Windows Mobile 6.5

    https://portal.motorolasolutions.com/Support/US-EN/Resolution?solutionId=88182&brand=emb

     

    CE 6.0

    https://portal.motorolasolutions.com/Support/US-EN/Resolution?solutionId=88182&brand=emb

     

    Also these issues have been addresed in the latest OS update for the MC9190 which can be downlaoded (after verification of entitlement) from the following links:

     

    OSUpdate Package v03.37.02 for MC91XX CE6.0

    Update Loader Package v03.47.02 for MC9190 WEHH 6.5 Classic

     

    Contact Motorola for additional support:

    www.motorolasolutions.com