Telnet making strange characters / Numerical Keys on M3 Orange keyboard making incorrect symbols / generating wrong value / USB Scanners return shifted characters

Version 7

    Verified Product Versions

    Wavelink Terminal Emulation 7.3Wavelink Terminal Emulation 7.0

    Environment(s):

    • TelnetCE 7.x and later
    • LXE Thor
    • M3 Orange with 27-Key keyboard
    • Pidion HM40 Windows Mobile (WM) 6.5 with Wavelink Industrial Browser (WIB) version 7.03.02
    • USB Scanners
      • Datalogic - USB Scanner - D230STD
      • Motorola - USB scanner - LS3408

      • Intermec - USB scanner - SR61

      • Motorola - USB Scanner - DS9808

     

    Problem/Issue:

    • LXE THOR only showing first digit of a barcode
    • Numerical keys on the M3 Orange keypad are not making the correct character. For example, I press key '4' and it generates '$'.
    • Strange Characters appearing in Wavelink Telnet Emulation client (TelnetCE)
    • Pidion HM40 WM 6.5 w/ WIB vers. 7.03.02 getting characters like "&é"'("
    • USB scanned numbers coming in as shifted characters ( o 1=!, 2=", 3=£, 4=$, 5=%, 6=^, 7=&, 8=*, 9=( and 0=)
      • If Sticky keys doesn't work for the USB device issues, then try also Enabling "Use Scanner as a Keyboard Wedge"

     

    Resolution:

    Turning off 'Sticky Keys' in the Emulation Parameters resolves the issue.

    1. Open the Telnet Configuration Utility

    2. Open Emulation Parameters

    EmulationParameters_button.png

     

    3. Open to Emulation > Keyboard > Sticky Keys

     

    1.png

    4. Click Save to save the settings

    5. Send the configuration to the device

    6. Restart Telnet on the device.