The MP_ComputerPatchScan table can grow quite large

Version 1

    Verified Product Versions

    LANDESK Management Suite 9.5

    Problem:

    The MP_ComputerPatchScan table is the largest DB table, and or SQL transaction logs are filling up rapidly causing performance issues.

     

    Or MP queries are taking a long time to resolve.

     

    Query example

     

    INSERT MP_TaskMachinePatch (LD_Task_IDN, Computer_IDN, Vul_ID) SELECT DISTINCT tm.LD_Task_IDN, tm.Computer_IDN, cp.Vul_ID FROM MP_TaskMachine tm 
    WITH (NOLOCK) 
    JOIN MP_ComputerPatch cp 
    WITH (NOLOCK) ON tm.Computer_IDN = cp.Computer_IDN AND tm.Vulnerabilities LIKE '%' + cp.Vul_ID + '%' LEFT OUTER JOIN MP_TaskMachinePatch tmp 
    WITH (NOLOCK) ON tmp.LD_Task_IDN = tm.LD_Task_IDN AND tmp.Computer_IDN = tm.Computer_IDN AND tmp.Vul_ID = cp.Vul_ID 
    WHERE tm.LD_Task_IDN = 476 
    AND tmp.LD_Task_IDN IS NULL 
    

     

    Cause:

    The MP_ComputerPatchScan table is a table that was added so customers could get patch Data in DA as well as patch but it can grow extremely large and could affect performance.

     

    Solution/ Workaround:

     

    Disable the Managed Planet Task Listener service and then truncate the table.

     

    This service is disabled by default in LDDA 9.51 patch build 99 and above.

     

     

     

    Note:

    You can re-enable that process if needed\desired but do so with extreme caution as this data can grow extremely large and extremely fast.