"Engine attempted to enter state EngineFailed but is in state"DataSyncComparisonInProgress..." error in Test To Live

Version 4

    Verified Product Versions

    LANDESK Service Desk 7.7.xLANDESK Service Desk 7.8.xLANDESK Service Desk 2016.xLANDESK Asset Central 2016.x

    Problem

    When running Test To Live you see the following error during synchronisation:

     

    no disk space.JPG

    Progress status: Comparing database data...

    Error Message: Engine attempted to enter state EngineFailed but is in state DataCyncComparisonInProgress (expected state DataSyncInProgress)

     

    In the Test To Live log the last entries look like:

     

    [11:06:49] RedGate - Comparing [dbo].[tps_attachment_data]

    [11:56:59] Engine - State Change - Need: 'DataSyncInProgress', Current: 'DataSyncComparisonInProgress', New: 'EngineFailed'.

    [11:56:59] Engine - State Change - State is incorrect, aborting!

     

    Cause

    This error can occur when the PC running Test To Live is low on disk space.  For Test, To Live to compare databases it can use up to the size of both Test and Live databases combined in disk space.  For instance, a 2GB Live database and 2GB Test database require up to 4GB of disk space available to run Test To Live.

     

    The file space is used up in temporary files that are removed as soon as the synchronisation is complete.  The files are stored under the logged in user's Temp folder.

     

    Solution

    Re-run Test To Live on a PC with more available disk space.

     

    Update 16/11/2016

    We added a PowerShell script to assist in the task of setting the temp variable temporarily to a new folder prior running Test to Live.