Only can manage one 1 device at a time in Avalanche / gold image enabler / same uuid / same deviceid

Version 8

    Verified Product Versions

    Wavelink Avalanche 6.1Wavelink Avalanche 5.3Wavelink Avalanche 5.2Wavelink Avalanche 5.0Wavelink Avalanche 4.8Wavelink Avalanche SE 5.3Wavelink Avalanche SE 5.2Wavelink Avalanche SE 5.0Wavelink Avalanche SE 4.8

    Environment:

    • Avalanche Universal Enabler 5.x and newer
    • Avalanche Mobility Center / Site Edition / Avalanche 6.0
    • Mobile Devices:
      • Unitech HT682
      • Pidion HM50
      • M3 T (See the "Try Universal Enabler / Device Specific Enabler" solution)

    Problem:

    • After installation we created a golden image from the pilot device and installed it on 80 machines. Now we have the problem that all devices appear to come up with the same ID so that just one device can connect.
    • I can only use or manage or control one ( 1 )  device at a time
    • Only one ( 1 ) device is manageable at a time
    • My devices have duplicate Terminal ID, GUID, or DeviceID

     

    Cause:

     

    Context: The GUID (Globally Unique Identifier) is generated by the device itself based on the uniquedeviceid api on the device. The TerminalID is an avalanche parameter that is autogenerated from the GUID of the device. When two devices have the same GUID, then they will have the same TerminalID. This makes it so only one of them appears at a time.


    There are a few reasons this could be happening:

    • If you are using a 'Gold Image' to build your devices, then they will all have the same GUID (which is stored in the _Local.prf, _local.prf.opf, _devprop.prf and _devprop.prf.opf files of your enabler folder)
    • If your device's uniquedeviceid api is the same on all devices AND you are using a universal enabler
      • Some manufacturers have duplicate uniquedeviceid across all of their devices (such as Pidion).

     

    Solution(s):

    There are three solutions you should try:

    • Try Universal Enabler / Device Specific Enabler
    • Delete the _local.prf _local.prf.opf
    • Disable GUID Generation Registry


    Try Universal Enabler / Device Specific Enabler:


    Delete the _local.prf _local.prf.opf

    Try this first (especially if you are using a Gold Image to build your devices)

    1. On the device (Remote onto) the device navigate to the config folder.
      NOTE: Usually the config directory is in either \Program files\wavelink\avalanche config (Window mobile) or \Application\wavelink\avalanche\config (CE).
    2. Delete the following files: _Local.prf, _local.prf.opf, _devprop.prf and _devprop.prf.opf
    3. Reconnect to the AMC server via the enabler
      • In the enabler on the device, File > Connect (Connect to the AMC Server)

     

    Disable GUID Generation Registry

    If the above does not work, then please try this:

     

    • Add the below registry entry prior to the device connecting to the Avalanche server. Make sure you set it to 0 to disable the device GUID connect before connecting.
      • This will allow to pull a GUID from the MDS instead of generating it.

     

    Disable GUID Generation (4.06 and up)

    HKEY_LOCAL_MACHINE\SOFTWARE\Wavelink\Avalanche

    Dword = GenerateDeviceGUID

    Value = 0 (disabled) or 1 (Enabler)