Issue: The IP address of the managed device isn't updated - the IP address of the wrong network connection is reported

Version 11

    Verified Product Versions

    Endpoint Manager 9.5Endpoint Manager 9.6Endpoint Manager 2016.xEndpoint Manager 2017.xEndpoint Manager 2018.x

    Issue

    • After having changed IP address on a managed device, the inventory data in Management Console keeps showing the old IP address
    • The Management Console reports the IP address of a network connection that is not the one the managed device is using to communicate to the Core Server
    • The IP reported in the in the Management Console is not correct so it's not possible to remote control the managed device
    • The inventory of the virtual guest computers report the wrong IP address, using the localhost address rather than the actual network IP address
    • It's not possible to schedule a task targeting these computers as the Management Suite is not pointing to the right destination IP address.
    • Vulnerability scan is not returning results to the console.

     

    Cause

    There are a few reasons why this can happen, the most common are the following.

    1. The option Encrypted Data Transport is enabled in the Inventory server settings.
    2. The option Use Connection Address is set to 0 in the Advance settings of the Inventory server settings.
    3. LDMS Network View -> Configuration -> Pending unmanaged client deployments are still showing the devices in question.
    4. The network interface used to communicate to the Core Server doesn't precede the other interfaces in the binding order.

     

     

     

    inventory_server_settings.png

     

     

    Resolution

    1. In the LANDESK Management Console, go to Configure > Services > Inventory and deselect the option Encrypted Data Transport.
    2. In the LANDESK Management Console, go to Configure > Services > Inventory > Advanced settings and set to 1 the option Use Connection Address.
    3. In the LANDESK Management Console, go to Network View -> Configuration -> Pending unmanaged client deployments, delete the devices showing, run Umanaged Device Discovery (UDD).
    4. On the device affected by the issue, open the Network and Sharing Center, then click on Change adapter settings

              Press the ALT key, click Advanced, and then Advanced Settings.
              If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

              Click the Adapters and Bindings tab.

              Under Connections, click the connection the device is using to communicate to the Core Server and move it on the top of the list.

              Under Bindings for <connection name>, select the protocol that you want to move up or down in the list.
              Click the up or down arrow button, and then click ok.

     

     

    adpaters_bindings.png

     

     

    Other resources

     

    [Microsoft Technet] DNS: Valid network interfaces should precede invalid interfaces in the binding order