Process ID numbers jump by 1000 for no reason

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    Problem

    The ID number for any process module (Incident, Problem, Request, etc) jumps up by 1000.  For example you create an incident and it is given ID 1234, then you create another incident and it has ID 2234 instead of 1235.

     

    Cause

    This is caused by a change to the IDENTITY feature in SQL Server from version SQL Server 2012 and will occur any time the SQL Server service or server is restarted.  This has been seen as a bug by some but Microsoft have stated this was an intentional change.  IDs in SQL Server are designed to be unique but not necessarily sequential.  See this link for more details: Failover or Restart Results in Reseed of Identity | Microsoft Connect.

     

    Solution

    In the link above, Microsoft have advised the behaviour of the IDENTITY feature can be reverted to that of version 2008 R2.  This is done by adding a trace flag as a startup parameter to the service.  There is little information at the moment on how supported this is but at least for now this does work and does not appear to have any other consequences.  However this should be tried at your own risk.

     

    The link above includes the details of this but this blog post gives a better explanation: Using trace flag 272 in SQL and solve the dentity Problem SQL 2012.