Issue: 'Configuring certificate for web services' action fails during installation

Version 7

    Verified Product Versions

    LANDESK Management Suite 9.6LANDESK Management Suite 2016.x

    Issue

    Error 'Configuring certificate for web services' errors when you installing the LDMS product on a windows server

     

    Cause

     

    This can be caused by a GPO blocking the creation and self-signing of the certificates that we use and create during the installation process:

    Example:

    2014-10-13 17_09_43-CUST-D1_janadmin on CUST-D1_PCMGMT-CORE01.png

    This GPO option prevents the certificates from getting created correctly causing the installer to error.

     

    Another potential cause is related to a misconfigured virtual directory in IIS for BridgeIt.  If this is the case, you will see the following error in the install log:

    Error: Unable to find virtual directory (Program.AddSTSAndEncryptionThumbprintToWebConfig())

    Resolution

    Remove the GPO from targeting the LANDESK LDMS core.  In case of the second cause, open IIS, expand default website and select the BridgeIt virtual directory.  Go to advanced settings and ensure the path is set to C:\Program Files\Landesk\Bridgeit.