Error: "Login failed for user 'LDMSAdmin' during service update installation

Version 27

    Verified Product Versions

    LANDESK Management Suite 9.5LANDESK Management Suite 9.6

    Issue

     

    Upgrading the LDMS Core fails and gives prompt:

     

    Login failed for user 'LDMSADMIN'

    Note:the popup may be hidden behind other windows. If the upgrade appears frozen, move the windows on the screen around to reveal the popup.

     

     

     

    1-prompt.png

     

    Cause

     

    In some cases, the ldcryptoconfig.xml file is missing or corrupted from the Keys directory on the Core Server (C:\Program Files\LANDesk\Shared Files\Keys) which causes the upgrade to fail.

     

     

    Solution

     

    • Keep clicking Ok on the "Login Failed for user..." box until you get to a screen that you can click cancel. You may need to move the screen multiple times to click Ok to move forward. Go ahead and cancel the upgrade.

    2-errored.png

     

    • Rename the ldcryptoconfig.xml file in \Program Files\LANDesk\SharedFiles\Keys folder (if this file does not exist move to the next step)
    • In all programs, please click on LANDESK -> LANDESK Configure Services and re-enter your database information.
    • In the registry key (HKEY_LOCAL_MACHINE\SOFTWARE\LANDesk\ManagementSuite\Core\Connections\Local) rename the PWD Scheme
    • In HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\LANDesk\ManagementSuite\Core_x86\Connections\Local make sure the user and password values match the values in the 64 bit registry key (HKEY_LOCAL_MACHINE\SOFTWARE\LANDesk ManagementSuite\Core\Connections\Local) if they don't match you will get an error that the password does not match. (if these keys do not exist move on to the next step)
    • Run each of the following commands separately from an ELEVATED COMMAND PROMPT. (The default paths are listed below. Please change the path if you extracted the service pack to a different location)

     

     

    NOTE: THERE HAVE BEEN NUMEROUS CALLS BECAUSE OF PEOPLE TYPING IN THE COMMANDS WRONG.
    PLEASE COPY AND PASTE THE COMMANDS BELOW- THIS EXAMPLE IS FOR SP3 TO FIX LATER SERVICE PACKS REPLACE THE SP#

     

     

    • "C:\LANDesk_Patches\LD960-SP3-Core\Updates\1\image\ldcryptoconfigutil.exe" /symmKeySize=256 /symmAlgorithmid=AES /symmBlockMode=CBC
      • You can confirm this is successful by browsing to Program Files\LANDesk\SharedFiles\Keys and verify a new ldcryptoconfig.xml has been created.
    • "C:\LANDesk_Patches\LD960-SP3-Core\Updates\1\image\LANDESK.DataServices.PasswordPromotion.exe" /promote
    • "C:\LANDesk_Patches\LD960-SP3-Core\Updates\1\image\LANDESK.DataServices.PasswordPromotion.exe" /validate (If the promoted password doesn't match conduct the following, if it matches move on to /commit)
    • "C:\LANDesk_Patches\LD960-SP3-Core\Updates\1\image\LANDESK.DataServices.PasswordPromotion.exe" /demote
    • "C:\LANDesk_Patches\LD960-SP3-Core\Updates\1\image\LANDESK.DataServices.PasswordPromotion.exe" /validate (If the promoted password doesn't match repeat the above steps - starting with renaming the ldcryptoconfig.xml file)
    • "C:\LANDesk_Patches\LD960-SP3-Core\Updates\1\image\LANDESK.DataServices.PasswordPromotion.exe" /commit

    These will give an error if they fail to run.

     

    • Reboot the core, and then restart the install.
    • If the steps above do not work, please get to the screen where you can cancel the installation, and then contact support.

     

    Note: This issue could also occur while upgrading from 9.5 SPx to 9.6