Add Reminders Are Not Being Sent

Version 5

    Verified Product Versions

    Service Desk 7.7.xService Desk 7.8.xService Desk 2016.xAsset Manager 2016.xService Desk 2017.x

    Problem:

    Add reminder are not being sent, and the reminder is not getting the 'Active' check-box setting removed.

    The Add Reminder shows in the History of the ticket, but the reminder is not in the tps_user_message table in the database to get processed and sent out.

    The System Application log shows error on the Background service - 'The Knowledge Message Monitor task failed with the following error message: The network name cannot be found.'

     

    Cause:

    Free Text Search Index Path was not valid in the Framework

    The background service checks the 'Free Text Search Index Path' when starting, to validate it exists and that it can be accessed. If it is not a valid path, the service will not start.

     

    Resolution:

    This can be resolved by clearing out the Free Text Search Index Path from the framework, if this is on test and you do not already have a share or need a special location for the index files, so that the default path would be used.

    If you want or need a shared location, make sure that you can take the URL or local path from the Free Text Search Index field in the Framework and access it via a web browser or Windows Explorer, depending on the type of access that is defined by the path.

     

    You will then want to restarted the Background service and validate there are no longer errors on the Background Service.