CSA does not detect any update automatically

Version 6

    Introduction:

     

    CSA (Cloud Services Appliance) also known as former Management Gateway is a virtual (vCSA) or physical device which is used to provide management functionalities and secure communication between core servers and managed nodes across the internet. This appliance is based on a LANDesk patented technology which provides a high level of security among other functionalities. Keeping the device updated, is paramount in maintaining high level of security in your business.

    Some customers which own the virtual appliance might have noticed that when they press the button "Scan for updates", no updates are found although the CSA version is outdated.

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    Environment:

    Cloud Service Appliance versions dev 123 and dev130

     

    Requires Access To:

     

    -Root credentials on the appliance.

    -Access to the virtual device either from the virtual machine or through SSH if enabled from the Security tab.

    How To: Use Putty to SSH Into the LANDESK Management Gateway Appliance.

     

    Error message:

    There is no error message however, the Scan complete message is shown and no updates are available.

    Problem:

    No automatic updates are shown.

     

    Cause:

    It is known that vCSA versions dev 123 and 130 have their cache already full. This leads the appliance to skip the update process since there is no space available to accommodate new downloads.

     

    Solution / Workaround:

     

    There are currently 2 possible solutions to solve this issue.

     

    Solution 1

    Patch the appliance manually to the latest update and then the new release will be not affected by the issue above.

    How To: Download and Patch the 4.3 Cloud Service Appliance Manually

     

    Solution 2

    Remove the content of the cache manually. Proceed with this steps at your own risk and It is suggested to make a full backup/snapshot before proceeding.

    Steps:

    1. Press ALT+ F2 on your keyboard;
    2. write "xterm" in the prompted window and press enter;

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    3. type the following commands in the terminal to have root access.

    1. "sudo su";
    2. enter the admin password;
    3. press enter and the root access should be granted;

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    4. type the command " rm -rf /opt/landesk/ldms/LDClient/cache/* "

    5. press enter and the content of the cache folder should be erased. This will give the appliance enough space to accommodate the new updates.