ConfigurationCenter login policy settings do not match IIS Settings

Version 2

    Verified Product Versions

    LANDESK Service Desk 7.6LANDESK Service Desk 7.7.xLANDESK Service Desk 7.8.xLANDESK Service Desk 2016.xLANDESK Asset Central 2016.x

    Environment:

    ServiceDesk 7.x

     

    Problem:

    When changing the login policy in ConfigurationCenter the settings in IIS do not match the changes, which causes problem when trying to login into ServiceDesk

     

    Cause:

    Changes to the web.config file are preventing the updates.

     

    When changing setting in ConfigurationCenter it writes to the ApplicationHost.config file which is the root file of the configuration system when you are using IIS 7 and above. It includes definitions of all sites, applications, virtual directories and application pools, as well as global defaults for the web server settings (similar to machine.config and the root web.config for .NET Framework settings).

     

    When you make certain changes directly in IIS Manager for example "Authentication" this is written to the web.config file and this take precedence over the ApplicationHost.config file.  So if you have multiple Virtual Directories or Sites using the one web.config file this can cause some issues.

     

    Solution / Workaround:

    Remove the lines that have been added in the web.config file and update the ApplicationHost.config file (Please refer to Microsoft documentation ).

     

    In General

    Use ConfigurationCenter to make the changes you need for your ServiceDesk instance and if you need to make changes that are not available, you can update the ApplicationHost.config file (after guidance from Microsoft documentation )