"LANDesk Management Suite Has Stopped Working" Error When Launching Console

Version 5

    Verified Product Versions

    Endpoint Manager 9.5Endpoint Manager 9.6Endpoint Manager 2016.x

    Error message:

    LANDesk Management Suite Has Stopped Working error when trying to launch Console.

    Capture.PNG

     

    Problem 1:

    Users are not able to open the Console on the Core Server.

     

    Cause:

    SQL Server Connection unavailable.

     

    Solution / Workaround:

    Have user fix issues related to the SQL server.

     

    Additional information:

    This is the error message that was logged in the Console log when the SQL server failed:

     

    07/13/2015 15:22:44 ERROR 5288:Main Thread DataServices : Connection property, connection check exception for <DBNAME> on : System.Data.SqlClient.SqlException (0x80131904): A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - No connection could be made because the target machine actively refused it. System.ComponentModel.Win32Exception (0x80004005): No connection could be made because the target machine actively refused it

     

    Any attempts to open the Console after that will yield this error:

     

    07/13/2015 15:47:38 INFO  7080:Main Thread RollingLog : There is an error in XML document (2, 3).

    07/13/2015 15:47:55 INFO  7080:Main Thread RollingLog : Critical Exception: System.InvalidOperationException: Response is not well-formed XML. ---> System.Xml.XmlException: ' ', hexadecimal value 0x01, is an invalid character. Line 6, position 52.

     

     

    Problem 2:

    Problem signature:

      Problem Event Name:    CLR20r3

      Problem Signature 01:    console.exe

      Problem Signature 02:    9.60.2.48

      Problem Signature 03:    54198708

      Problem Signature 04: System.Web.Services

      Problem Signature 05: 4.0.30319.17929

      Problem Signature 06:    4ffa80c0

      Problem Signature 07:    1a9

      Problem Signature 08:    42

      Problem Signature 09: System.InvalidOperationException

      OS Version:    6.1.7601.2.1.0.400.8

      Locale ID:    1033

      Additional Information 1:    1856

      Additional Information 2: 1856399f014cad150d4895f56522f971

      Additional Information 3:    65cf

      Additional Information 4: 65cf9a21560a17d7261d534b9366a7dd

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    Cause:

    IIS Application Pool is pointing to the incorrect .Net version.

     

    Additional Information:

    Console.exe.log showed error: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.

     

    Solution:

    1. Launch IIS Manager, Expand LDMS node.
    2. Select Application Pools
    3. Right-click on LD component
    4. Select Basic Settings
    5. Set .Net CLR Version: to be correct. (If already set correctly, set to a previous version, apply, then reset to the correct version), Click OK
    6. Restart IIS
    7. Try logging into the console now.

     

    35298-2.png

     

    Problem 3:

     

    APPCRASH

    Application Name:LANDesk Management Suite.exe
    Application Version:10.1.0.168
    Application Timestamp:57e31df9
    Fault Module Name:KERNELBASE.dll
    Fault Module Version:6.3.9600.18340
    Fault Module Timestamp:57366075
    Exception Code:e0434352
    Exception Offset:0000000000008a5c
    OS Version:6.3.9600.2.0.0.272.7
    Locale ID:1033
    Additional Information 1:f18a
    Additional Information 2:f18a865cd1cc89894e9d42aca5526392
    Additional Information 3:5927
    Additional Information 4:5927fe4d32b0e16fa57b08763ead8f4b

     

     

    Read our privacy statement online:

    http://go.microsoft.com/fwlink/?linkid=280262

     

     

    If the online privacy statement is not available, please read our privacy statement offline:

    C:\Windows\system32\en-US\erofflps.txt

     

     

    Cause:

    Broken shortcut on the desktop

     

    Additional information:

     

    Solution: Try running C:\Program Files\LANDesk\ManagementSuite\console.exe directly. If it works, create a new shortcut on the desktop.