Problem / Solution: Test To Live (TTL) doesn't transfer all the objects for a SQL Database which has initially been an Oracle DB

Version 2

    Verified Product Versions

    LANDESK Service Desk 7.6LANDESK Service Desk 7.7.xLANDESK Service Desk 7.8.x

    Error message:

    No error message in the Test-To-Live logs noticed, but the Redgate engine doesn't compare the tables.

     

    Problem:

    If you have just transformed your Oracle Database into SQL Database to benefit from the Test-To-Live capabilities, you may notice that some objects you added in the TEST Database (i.e. From Object Designer, Windows Manager etc.) are not transferred to the LIVE Database.

     

    Cause:

    It may due to the tool you have used to convert the Oracle DB into a SQL DB. If you use, for example, a product like Full Convert, it may leave all of the tables and columns in upper case which prevents TTL to understand some tables and stored procedures.

    When you add an object on the LDSD Console, it alters some tables and adds some rows in others. And, due to this issue, some alterations and rows are not transferred to the LIVE DB through TTL.

     

    Solution / Workaround:

    To resolve this, during the conversion of the Oracle DB, you may find an option "Leave Case Sensitivity" which should be something "all to lower case" (This is at least the case of Full Convert product). It will basically transform these stored procedures, and such into lower cases. Then TTL will be able to handle this.