"Failed to open the connection. Details: [Database Vendor Code: 17 ]" when clicking the "View report" button in WebAccess

Version 10

    Verified Product Versions

    LANDESK Service Desk 7.6LANDESK Service Desk 7.7.xLANDESK Service Desk 7.8.xLANDESK Service Desk 2016.xLANDESK Asset Central 2016.xLANDESK Asset Central 2017.xLANDESK Service Desk 2017.x

    Environment:

    Landesk/Ivanti Service Desk (All Versions)

     

    Requires Access To:

    LDSD/ISD Web Server

     

    Error message:

    When clicking the "View report" link in Web Access, you get the following error:

    Failed to open the connection. Details: [Database Vendor Code: 17 ] Failed to open the connection. IncidentManagement.Incident {guid}.rpt Details: [Database Vendor Code: 17 ]

     

    Cause:

    The Crystal report generated when you click the "View report" button has not been configured to access your Service Desk database, or the database connection details have changed.

     

    Solution:

    To identify where the Crystal reports used by Web Access are located, log into Configuration Center and edit the Web Access framework. The Reports path is displayed at the bottom of the window:

    The default value is C:\ProgramData\LANDesk\ServiceDesk\[Service_Desk_Instance_Name].WebAccess\Reports

     

    Once you know where the reports are stored, open the Crystal Reports DSN Setter tool located in [installation_drive]:\Program Files (x86)\LANDESK\Service Desk\Reports\CrystalReportsDSNSetter.exe:

    Select the report folder that you have identified above, complete the data source connection details, and click Run. The program will update the database connection details in all the reports located in the Reports folder.

     

    A file called LogFile.txt is created in the same folder as the DSN Setter tool, and will list any errors which would occur during the process.