My script fails to run / Scripting not enabled or initialized

Version 1

    Verified Product Versions

    Wavelink Naurtech CETerm 5.7

    Environment:

    • CE Term 5.7

     

    Issue / Problem:

    • My script fails to run
    • "Scripting not enabled or initialized"

    Cause:

    • Script not loaded into CE Term
    • Script not loaded correctly
    • Scripting not enabled
    • Your script requires loading when the application starts
    • Incorrect or insufficient permissions or access rights

     

    Resolution:


    Is the script loaded into CETerm?

    You can verify this by seeing the entry for the script in the table. Go to Session -> Configure -> Options -> Configure Scripting -> Scripts and look through all the scripts loaded in the table. You can highlight a script and press the Edit button to see the actual script. The script that you are running requires to be loaded.


    Verify that the right script loaded

    Like any program, debugging scripts is an iterative process. Make sure that the script that you think you are running is indeed the correct one. You can follow the steps above to verify this.


    Is Scripting enabled?

    Scripting feature is not enabled by default. You must enable the setting Session -> Configure -> Options -> Configure Scripting -> General -> Enable in CETerm.


    Does your script require to be loaded when the application starts?

    This depends on what you are doing in your script. Certain scripts may provide handlers for one of the pre-defined events or include functions and therefore may require to be loaded at startup. This ensures that the script is available when the "event" happens. Please make sure your script configured with this option if required. You can enable this under Session -> Configure -> Options -> Configure Scripting -> Scripts -> Edit


    Do you have access rights?

    Some scripts may try to include operations to

    • access the device registry
    • read or write from a file
    • launch a program

    If your script does one of these, then you must enable the corresponding rights under Session -> Configure -> Options -> Configure Scripting -> General

    • Validate your script syntax for correctness