Allowing Assignments before the Closed status

Version 5

    Problem

    Having added an automatic assignment action to a process just before the Closed (or End type) status an error occurs when performing the Close action:

     

    Invalid assignment: Cannot assign a process that has reached an end status.

    Cause

    This is caused because in a purely logical sense there's not a lot of point in assigning something to someone right before putting it at a status where no one needs to do anything with it.  In reality, using assignments before the close status is quite useful for a couple of reasons:

    1) Ensuring that the item will be assigned to an appropriate group if it is re-opened

    2) Using the assignment to notify a User that the item is being closed.  In versions after 7.2.3 a reminder can be used instead of an assignment to achieve this.

     

    Solution

    A key can be added to the tps.config file that allows the assignment to be carried out before the closed status without causing an error.  The key is

     

    <add key="AllowAssignClosedProcesses" value="True" />


    The key needs to be added to all tps.config files that any Console, Service Portal or Web Access platform logs into.  These are located in the relevant folders (Touchpaper.Framework.Web, ServicePortal and WebDesk) on a 32bit system at: C:\Documents and Settings\All Users\Application Data\Touchpaper\ and on 64bit systems at: C:\ProgramData\Touchpaper\. From 7.6 on onwards the folder location is C:\ProgramData\LANDesk\ServiceDesk.

     

    The key should be added on a new line anywhere between the <appsettings> and </appsettings> lines.

     

    Note: Please ensure no one is logged in to Console, Service Portal or Web Desk when these changes are made.  An IIS reset may be required for the change to take effect.  It is recommended that a backup of the tps.config files are taken before altering them so they can be reverted to if required.

     

    Environment

    All versions of LANDesk Service Desk