Turning off smart linking in Crystal Reports X (10)

Version 3
    Question

    How do I switch off the auto smart linking in Crystal Reporting?

    Answer

    1. Close Crystal Reports.

    2. On the 'Start' menu, click 'Run'.

    3. Type "regedit" in the 'Open' combo-box then click 'OK'. This opens the Registry Editor.

    4. Browse to the following registry sub key:

    HKEY_CURRENT_USER\Software\Crystal Decisions\10.0\Crystal Reports\DatabaseOptions

     

    5. Right-click the 'DoAutoSmartLinking' string value then click 'Modify'.

    6. Type 'No' in the 'Value data' text box then click 'OK'. Close the Registry Editor.

     

    You can now create a report with multiple tables without automatically linking them.   You will need to exit and re-open Crystal first.

    Environment

    Crystal version 10 - see Article below for CRXI

    http://community.landesk.com/support/docs/DOC-4063