Problem / Solution: Impossible to update/install the last patch on the CSA / Gateway - Manual installation

Version 4

    Verified Product Versions

    LANDESK Management Suite 9.5LANDESK Management Suite 9.6

    Environment:


    CSA 4.3+

     

    Problem:


    When you try to install the Available Update from the CSA user interface (System > Update tab), you don't see the version number in "LANDESK Cloud Services Appliance Release" increasing and corresponding to the patch number after its installation (See below, where you try to install patch GB174, but the value remains 171)

     

         1.png

     

    Cause:


    It may happen at some point hence you need to install it manually.

     

    Solution / Workaround:


    1- To install it manually, you need first to download the patch on a Windows machine for example, from the following article; How To: Download and Patch the 4.3 Cloud Service Appliance Manually)

         In my case, I downloaded it in my Download folder.

     

    2- Then you need to create an SSH connection to your CSA machine with the help of puttty (See printscreen below and article How To: Use Putty to SSH into the LANDESK Management Gateway for more details)

         In my case, I used the internal IP address of my CSA and default port 22 with the Encryption AES

    2.png

     

    3- Here are the commands to go through (In this example, I installed GSB 174):

     

    Login as: admin
    <Type the admin password you defined in the CSA>
    cd /tmp
    mkdir ./mnt1
    sudo mount -t cifs //10.1.1.2/c$ ./mnt3 -o username=<WINDOWS_USERNAME>,password=<WINDOWS_PASSWORD>,domain=<YOUR DOMAIN>
    <Type the admin password you defined in the CSA>
    cd /tmp/mnt1/users/<WINDOWS_USERNAME>/downloads/
    cp GSB431_174.tar.gz /tmp
    cd /tmp
    sudo tar -xzvf GSB431_174.tar.gz
    <Type the admin password you defined in the CSA>
    cd GSB431_174
    chmod +x ./patch.sh
    sudo ./patch.sh
    <Type the admin password you defined in the CSA>
    

     

    4- On the CSA user interface, go in System > Appliance tab > Click on Reboot

     

    This will be now effective.