Error 500 after installing Xtraction 15.1

Version 2

    Without all the necessary Web Server (IIS) prerequisites in the Application Development, Xtraction will return errors when trying to connect to the configured app pool.

     

    Environment:

    Xtraction 15.1

     

    Error message:

    Error 500.19 - Internal Server Error

    afSXo.jpg

    Problem:

    Error when loading the Xtraction web page for the first time following installation.

     

    Cause:

    There are missing prerequisites described in the installation documentation.

    This image is an example of the necessary prerequisites.

    prereqs.JPG

     

    Solution / Workaround:

    On new install please verify ALL prerequisites are installed from the Installation Guide to prevent errors with the configured application pools in IIS.