Error 401 when trying to open the Xtraction Windows authentication portal

Version 3

    Cause:

     

    Windows authentication is not added as a feature of IIS, enable for the application, or is not able to access to a Provider to allow users to authenticate.

     

    Resolution:

     

    There are several features that need to be installed and enabled for Windows Authentication to pass through IIS.

     

    1. Make sure in Roles and Features the option Web Server (IIS) - Web Server - Security - Windows Authentication is checked and installed. If the option is checked but you still are not seeing the option to enable Windows Authentication in the configured application you may need to perform an IIS reset or a restart of the system.

    IISfeatures.PNG

     

    2. For your Xtraciton configured application open the security settings and confirm Anonymous Authentication is disabled and Windows Authentication is enabled.

    ApplicationAuthentication.PNG

     

    3. If you are still getting the unauthorized error also check the Advanced Settings has the option Enable Kernel-mode authentication enabled

    KernalAuth.PNG

    And in the providers of the Windows Authentication, Negotiate and NTLM show in the Enabled Providers box and in that order

    Providers.PNG

     

    ***Important Note***

    All of these items are subject to the security implementation of your environment and may not be exactly the same. To ensure the authentication settings are correctly configured for your environment consult with your Server and Security administrators.