ERROR: Failed to reinstall Ivanti Antivirus (Kaspersky Engine) - Reboot is required

Version 8

    Verified Product Versions

    Endpoint Manager 9.6Endpoint Manager 2016.x

    This article refers to Ivanti Antivirus using the Kaspersky engine.  This article is not valid for Ivanti Antivirus 2017 (Bitdefender Engine)

     

    Issue

     

    Failed to install Ivanti Antivirus.

     

    C:\ProgramData\Landesk\Log\ldav_install.log shows the following error:

     

    ########################## Starting LDAV #####################################

    Mon, 28 Mar 2016 16:12:23 Log path: C:\ProgramData\Landesk\log\ldav_install.log, max size: 2097152

    Mon, 28 Mar 2016 16:12:23 main service: false, install: true, update: false, scan: false

    Mon, 28 Mar 2016 16:12:23 ----------------------------------

    Mon, 28 Mar 2016 16:12:23 ProcessId: 1764 instance: /install

    Mon, 28 Mar 2016 16:12:23 ----------------------------------

    Mon, 28 Mar 2016 16:12:23 *******************************

    Mon, 28 Mar 2016 16:12:23 Installing LANDESK Antivirus

    Mon, 28 Mar 2016 16:12:23 *******************************

    Mon, 28 Mar 2016 16:12:23 Set driver path: C:\Windows\system32\drivers\

    Mon, 28 Mar 2016 16:12:23 vulscan app path dir: C:\Program Files\LANDesk\LDClient\

    Mon, 28 Mar 2016 16:12:23 avp.exe does not exist, KAV not installed

    Mon, 28 Mar 2016 16:12:23 avp.exe does not exist, KAV not installed

    Mon, 28 Mar 2016 16:12:23 Cheking if Klif service installed and running...

    Mon, 28 Mar 2016 16:12:23 Service exists: true, service running: true

    Mon, 28 Mar 2016 16:12:23 A reboot is required before running setup, not running setup and returning E_FAIL

    Mon, 28 Mar 2016 16:12:23 ERROR: Failed to install LANDESK AV (0x80004005)

    Mon, 28 Mar 2016 16:12:23 Exiting WinMain: main service: false. rv: 0x80004005

      

    Cause

     

    During the uninstall process, not all files were correctly removed.

     

    Solution / Workaround

     

    First

    1. Navigate to C:\Program Files (x86)\LANDesk\LDClient\Antivirus\install\setup
    2. Start Kes10Win.msi > Remove > Check Operational settings of the application
    3. Press Next and continue to end of Wizard.
    4. Deploy agent and LANDESK AV on client

    Second

     

    1. Navigate to C:\Program Files (x86)\LANDesk\LDClient\Antivirus\install\setup
    2. Start Kes10Win.msi > Repair > Follow installation process
    3. When it will finish, reboot client
    4. Open the command line and navigate to C:\Program Files (x86)\LANDesk\LDClient\Antivirus
    5. Run "ldav /install"
    6. After 10-15 mins please check in Start > LANDESK Management > LANDESK Antivirus entry, reboot client.