Change upload file as attachment size limit by modifying web.config related to error "Request Entity Too Large. Server respond: 413"

Version 7

    Verified Product Versions

    Service Desk 7.6Service Desk 7.7.xService Desk 7.8.xService Desk 2016.xAsset Manager 2016.x

    We know Adding attachments via email now allows for attachments bigger than 3 MB - Service Desk 2016.1

    The below document shows how to modify the limit of attachement size when you try to upload a file by WebAccess or BridgeIT.


    The WebAccess and BridgeIT have different default upload file limit. You may set the limits in two files called web.config in two different folders.

    The 2016.1 WebAccess web.config file is located:

    C:\Program Files (x86)\LANDESK\Service Desk\WebApp\WebAccess\web.config

    <security>
        <requestFiltering>
            <requestLimits maxAllowedContentLength="52428800" maxQueryString="40800" maxUrl="51200" />
        </requestFiltering>
    </security>
    
    
    
    
    
    
    
    
    

    The default upload file size limit is 50MB in 2016.1 WebAccess as shown in the above script. You may change "52428800" bytes to the size you want.

     

    The 2016.1 BridgeIT web.config file is located:

    C:\Program Files (x86)\LANDESK\BridgeIT\web.config

    There is no default setting of the upload file size. So BridgeIT uses the default setting of IIS. The default setting is different regarding on IIS version.

    You may encounter below error when you try to upload a file, such as a file which size is 4MB on BridgeIT:

    "Request Entity Too Large

    Server response: 413"

    That error happens because the IIS has upload file size limit.

    You may change the web.config, line 17, under BridgeIT folder to change the upload file size limit as below, the example below is set the limit to 50MB:

    <httpRuntime targetFramework="4.5" enableVersionHeader="false" maxRequestLength="102400" />
    
    
    
    
    
    
    

    1.png

    Also you need to add below script:

    <system.webServer>
        <security>
              <requestFiltering>
                  <requestLimits maxAllowedContentLength="52428800" />
              </requestFiltering>
        </security>
    </system.webServer>
    
    
    
    
    
    
    

    2016-05-27 (3).png

    In this case, you set the attachement file size limit to 50MB (52428800 bytes).

     

    After modify the web.config file, you may need reset IIS and restart LDSD services to make the change take affect.