"ユーザが編集権限を持っているかどうかを読み取れません。 " もしくは "サーバー エラー" が SLM コンソールに表示される

バージョン 1

    "ユーザが編集権限を持っているかどうかを読み取れません。 " もしくは "サーバー エラー" が SLM コンソールに表示される

     

     


    検証済みバージョン

    LANDESK Management Suite 9.5

    LANDESK Management Suite 9.6

    LANDESK Management Suite 2016


     

     

    概要:

    - ダッシュボード及び製品のカテゴリを選択時、ソフトウェア ライセンス監視コンソールにデータが表示されない

    - 管理メニューで再計算実行時に "ユーザが編集権限を持っているかどうかを読み取れません。 " エラーが表示される

    - レポートを開いた際に "サーバー エラー" が表示される

     

     

    原因:

    コンソール及び SamServer の web.config 中に存在すべき STSCert 及び encryptioncert の各値が適切に

    登録されていない可能性があります。

     

     

    解決方法:

    - "C:\Program Files (x86)\LANDesk\ManagementSuite\landesk\managementsuite\sts" フォルダ配下のweb.config ファイルを開く

     

    - ファイル最下部へ移動し、<appSettings> セクションに以下の2種類のキー情報を追加する

      (例)

        <add key="encryptionCert" value="ODBCMzUyN0RGMzM5RUNBNkFENjE4MEY1NUFDQjE5NThGOTg0REFCNg==" />

        <add key="STScert" value="ODBCMzUyN0RGMzM5RUNBNkFENjE4MEY1NUFDQjE5NThGOTg0REFCNg==" />

      value= で指定する各値は環境によって異なります。


    - これらの2種類のキー情報を以下のフォルダ配下に存在する web.config ファイルの <appSettings> セクションに追加する

      "C:\Program Files (x86)\LANDesk\ManagementSuite\landesk\managementsuite\core\console\"

      "C:\Program Files (x86)\LANDesk\ManagementSuite\landesk\sam\samserver\"

     

    - IISを再起動する

    - Web ブラウザのポップアップを許可する

    - インターネット エクスプローラの拡張セキュリティ設定を無効にする

    - SLM コンソールへの接続を試行する

    - 必要に応じてインターネット エクスプローラのキャッシュをクリアする

     

     

     

    上記のステップを実施後にも引き続き

    "ユーザが編集権限を持っているかどうかを読み取れません。 "

    エラーが表示される場合は、次のステップへ進みます。

     

     

    原因:

    .NET 4.0 Frameworkがインストールされている環境に .NET 3.x Frameworkがインストールされた可能性があります。

    これにより、 ASP.NET 4.0 コンポーネントが IIS に正しく登録されていない可能性があります。

     

     

    解決方法:

    ASP.NET 4.0 コンポーネントを再度登録します。 Microsoft のナレッジベース KB 2015129 に詳細が記載されています。

    以下に手順の概要を示します。

     

    - コマンド プロンプトを管理者権限を持つアカウントで開きます。

    - 以下のディレクトリに移動します。

    (32 ビット)

    %windir%\Microsoft.NET\Framework\v4.0.30319
    

    (64ビット)

    %windir%\Microsoft.NET\Framework64\v4.0.30319
    

    - コンポーネントの再登録を実施します。

     aspnet_regiis.exe /iru
    

    - IIS サービスの再起動を実施します。

     iisreset
    

     

     

    その他の原因として想定されるものとして、 ".NET Framework 4.5" における "HTTP Activation" 機能が正しく有効化されていない

    可能性があります。こちらについても併せて確認を行ってください。

     

    英文

    'Unable to read whether the user has edit rights' or 'Server Error in /Console Application' errors show in the 9.5 SLM Console.