Issue: WinPE unable to load correct NIC driver during a provisioning task

Version 6

    Verified Product Versions

    Endpoint Manager 9.5Endpoint Manager 9.6Endpoint Manager 2016.x

    Issue

     

    During a provisioning task, you get the following error code when the client computer tries to boot into the WinPE environment:

     

                                           2016-07-01 22_51_30-Case Manager-040716.xlsx - Excel.jpg

     

     

    Timed out before acquiring an IP address.

    Windows IP configuration

    The operation failed as no adapter is in the state permissible for this operation.

    IP addresses: 127.0.0.1

    Waiting for IP address.....................................................................................................

    .....................................................................................................................................

    .....................................................................................................................................

     

    Timed out before acquiring an IP address.

     

         

     

    Cause

     

    This error means that WinPE is not able to find the correct driver for the network adapter of the computer being provisioned.

     

    As a result, the client computer is not able to acquire any IP address and the provisioning template fails.

     

     

    Workaround

     

    In order to fix this issue, please follow these steps:

     

    1. Check the exact version of WinPE shipped with your core server.

      About Windows PE versions used in LANDESK Management Suite

      For instance, if your core server has WinPE 5.0, you will need to download the driver for Windows 8.1 for the network adapter of the computer.  Please make sure to use only drivers compatible for Windows 8.1 as drivers for Windows 8.0 might not work properly.  If you use the 32 bit version of WinPE (win.boot), you will need to download the 32 bits version of the NIC drivers.  However if you use the 64-bit version of WinPE (win_x64.boot), you will need to find the 64-bit version of the NIC drivers.  Usually the NIC drivers can be found on the computer manufacturers websites in the support section.

      However there are situations where no NIC drivers are available for Windows 8.1. In other cases, the manufacturer will only provide the 64-bit version of the drivers for the network adapter, which might be an issue if you plan to use the 32-bit version of WinPE to boot the computer.  If this happens, the best way to proceed is to check directly on the NIC manufacturers website.  If the computer is equipped with an Intel network card (for instance Intel I219-V), you should be able to find the correct drivers on this page:

      https://downloadcenter.intel.com/download/23071/Network-Adapter-Driver-for-Windows-8-1-

      If the computer is from DELL, you can check this
      document.

    2. Once you have found the correct drivers,  you just need to inject them into your WinPE iso.

      How To: Add Drivers to WinPE for LANDESK OS Provisioning

      The last step will be to redeploy the PXE representative in order to update the WinPE iso.

    3. How To: Redeploy PXE Representatives

      Try to restart the provisioning task to test.

     

    If the correct driver was injected in step 2 the machine should now be able to successfully boot into WinPE.