Prerequisite Failed on Windows Server 2008 R2 Datacenter

Version 3

    Description

    When attempting to complete a full installation of Xtraction version 2016.2.6037.958 on a machine running Windows Server 2008 R2 Datacenter an error message is displayed stating that the Operating System does not meet the prerequisite requirements for the installation as seen in the example screenshot below:

     

    XtractionPrereqBug.png

     

    Resolution/Workaround

    This issue has been logged as a defect (ID: 329097) and will be resolved within a future release of Xtraction. In the meantime the following workaround can be implemented to allow the installation to continue:

     

    1. Copy the Xtraction installation media directly onto the machine in which it is to be installed.

     

    2. Navigate to {media location}\Resources and open the ProductProperties.xml using a text or XML editor.

     

    3. Locate the following lines within the XML file:

     

    <Prereq>

          <Name>pr_OS</Name>

          <Message>pr_OSDesc</Message>

          <Condition>HasValidXtractionOS</Condition>

          <ConditionScript>Install OR Upgrade</ConditionScript>

        </Prereq>

     

    and place these lines between comment brackets (<!--"..."-->). The end result should be as follows:

     

    <!--<Prereq>

          <Name>pr_OS</Name>

          <Message>pr_OSDesc</Message>

          <Condition>HasValidXtractionOS</Condition>

          <ConditionScript>Install OR Upgrade</ConditionScript>

        </Prereq>-->

     

    4. Save the changes and re-run the installation.

     

    This issue has since been resolved in Xtraction 2016.3 and later. Please proceed to the link below to obtain the latest installer:

     

    Xtraction 2017.2 Release Information