Issues With Scheduled Tasks After Installing a SU in LDMS 2016: Object Reference Not Set To An Instance Of An Object or Invalid Column Name 'TargetAllUsers'

Version 4

    Verified Product Versions

    Endpoint Manager 2016.x

    Environment:

    LDMS 2016

     

    Error message:

    Object Reference Not Set To An Instance Of An Object

    2016-07-29_08-14-27.png

    Invalid Column Name 'TargetAllUsers'

    2016-07-29_08-16-44.png

     

    Problem:

    Can't select "All Tasks" or create a new scheduled task.

     

    Cause:

    Missing 2 lines in the Datamart.XML after updating to SU3 or SU4.

     

    Solution:

    Backup your original Datamart.XML and then add the following line to the end of the LD_TASK and LD_Task_Template Column section in the Datamart.xml:

     

    <column name="TargetAllUsers" type="Int" null="No" default="1" />

     

    Example below:

     

    2016-07-29_08-36-51.png

     

    and

     

    2016-07-29_08-38-52.png

     

    Save the edited Datamart.xml and run CoreDbUtil.exe. Instructions below on how to run CoreDbUtil.exe

     

    How do I use Coredbutil.exe?

     

    Coredbutil.exe comes with the LANDesk Management Suite installation. It is located in the root folder \Program Files\Landesk\ManagementSuite. Before using DBRepair.exe complete the following:

     

    1. Close all web consoles, remote consoles and the core console

    2. Turn off the LANDesk Inventory Server service

    3. Launch CoreDbUtil.exe. The heading bar should say Datamart.xml.

    4. Choose Build Components and allow the utility to run. The amount of time varies from 5 to 15 mins.

    5. Start the inventory service and relaunch the console.

    6. You should now be able to create and view scheduled tasks.

     

    Second Possibility: TargetAllUsers Column Name Missing From ld_task table

     

    Close out of the Core Console.

     

    In SQL Management Studio run the following command on the LDMS DB:

     

    sp_help ld_task

     

    The last Column Name of the table should be TargetAllUsers:

     

     

     

     

    If this column name is not present, backup the Database then run the following command against the LDMS DB:

     

    alter table ld_task

    add TargetAllUsers int not null default (1)

     

    Check to ensure the column name has been added by running the original query:

     

    sp_help ld_task

     

    Relaunch Core console and check operation of scheduled tasks.