Self Service Anonymous login does not always work

Version 2

    Verified Product Versions

    Service Desk 7.7.xService Desk 7.8.xService Desk 2016.xAsset Manager 2016.x

    Environment:

    Service Desk Self Service Portal

     

    Requires Access To:

    Direct file access to C:\ProgramData\Landesk\Service Desk\ on all web servers.

     

    Problem:

    When using the anonymous login setup for Self Service some users are being automatically sent to the anonymous dashboard and some are sent to the login page. Using a different browser does not make a difference.

     

    Examples:

         Working user:

         Non-working user:

     

    Cause:

    When using a load-balanced web server environment setting the anonymous user login for Self Service is saved to the tps.config file at the current session the changes are made and do not carry across to the other web servers.

     

    Solution / Workaround:

    To resolve this issue the tps.config files will need updated on the other web servers manually. Locate the file in C:\ProgramData\Landesk\ServiceDesk\[InstanceName].WebAccess\tps.config on each of your web servers. One of those will have an entry near the bottom of the file for the Anonymous user and a value.

    <add key="AnonymousUser" value="SelfServiceGuest" />

    Copy the line to any of the tps.config files missing this entry into the same area of the file, save the changes, and perform an app pool recycle.

     

    Note: "SelfServiceGuest" maybe different in your environment.