Issue: Install fails at IIS installation step

Version 5

    Verified Product Versions

    LANDESK Management Suite 9.6LANDESK Management Suite 2016.x

     

    Issue

    During the install of LDMS, failure occurs at installing IIS. It fails on changing the PowerShell execution Policy.

     

    The setup log shows something like the following:

    2016-08-20 18:09:46 INFO: Executing command SetExecutionPolicy (SetupController.ExecuteNextCommand())

    2016-08-20 18:09:46 INFO: Executing: C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe Set-ExecutionPolicy Unrestricted (Launcher.ExecuteXmlCommand())

    2016-08-20 18:09:46 INFO: Notifying ProcessBegin: C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe (Launcher.ExecuteXmlCommand())

    2016-08-20 18:09:46 ERROR: Execution of SetExecutionPolicy completed. Return code: 1, State: Failure (SetupController.ExecuteNextCommand())

    2016-08-20 18:09:46 INFO: Serializing XML type: Setup.Common.Xml.SetupXml (SetupController.WriteXml())

     

    Cause

    The system is unable to set PowerShell's execution policy to unrestricted.

     

     

    Resolution

    You need to change PowerShell's execution policy.

     

    In PowerShell, you use the command as shown in the log "Set-ExecutionPolicy Unrestricted"

     

    If you are unable to change it with this command

    • You may need to move the machine to a different OU where the GPO is not enforcing a lower execution policy.
    • Find a domain administrator that is able to change this manually.

     

     

    NOTE: For more information about PowerShell Execution Policies, please visit Microsoft's TechNet website about_Execution_Policies.