Console Initialization Error: ParseLocalConnectionString When Launching the Console

Version 7

    Verified Product Versions

    Endpoint Manager 9.6Endpoint Manager 2016.x

    Description

    When attempting to launch LANDesk Management Suite you are presented with the error ‘Console Initialization Error: Error calling ParseLocalConnectionString Parameter name: local_conection_string’.

     

    err.png

     

    Resolution 1

    1. On the core server open the Internet Information Services (IIS) Manager. This can be accessed by navigating to the Control Panel > Administrative Tools > Internet Information Services (IIS) Manager. Alternately you can type in ‘inetmgr’ into the Start Search box and press Enter.

     

    2. Within the IIS Manager application navigate to the \[core server name]\Sites\Default Web Site\landesk\managementsuite\core\ssl\information folder.

     

    1.png

     

    3. In the middle pane double click on the ‘Authentication’ option within the IIS area as depicted in the screenshot below:

     

    2.png

     

    4. Please ensure the Authentication settings are set as follows:

     

    3.png

     

    Note: These are the default settings that are input into IIS upon installation of LANDesk Management Suite and are the suggested settings for IIS.

     

    5. Launch LANDesk Management Suite and attempt to login.

     

    Resolution 2

     

    1. On the core server open the Internet Information Services (IIS) Manager. This can be accessed by navigating to the Control Panel > Administrative Tools > Internet Information Services (IIS) Manager. Alternately you can type in ‘inetmgr’ into the Start Search box and press Enter.

     

    2. Within the IIS Manager application navigate to the \[core server name]

     

     

     

    3. Open ISAPI and CGI Restrictions

     

    4. Make sure that both ASP.NET v4.0 are allowed

    5. Launch LANDesk Management Suite and attempt to login.

     

    Resolution 3

     

    CoreDButil  Tries to communicate over SSL V3,   if it is disabled.   Then you can also get the ParselocalConnectionString Parameter name: local_connection_string’ message
    To check to see if SSL V3 is enabled Open regedit and browse to this location:
    go to the Key HKLM\Currentcontrolset\control\securityproviders\schannel\protocols\SSL 3.0\Server    Also check the client sections to make sure that,  "Disable by default is not set to 1.
    If you see SSL V3 is disabled  Dword = 1 change it to a "0".   You will need to restart the system after Making this change.

     

    Note: If you are experiencing the ‘Error: Exception! Error calling ParseLocalConnectionString Parameter name: local_connection_string’ message during an installation or upgrade, please visit the following community article for additional information and a fix for this issue. Core Install Fails at Configuring Datamart Step