Error: "Failed to load packages" in Portal Manager when refreshing

Version 4

    Verified Product Versions

    Endpoint Manager 9.6Endpoint Manager 2016.xEndpoint Manager 2017.x

    Issue

    Logon to system using domain user, In Portal Manager, click on Refresh, it pops up the error 'failed to load packages' while using local admin doesn't have the issue

     

    Info shown in Policysync.exe.log:

    10/17/2016 16:08:06 INFO  8392:1     RollingLog : Run PolicySync.exe

    10/17/2016 16:08:06 INFO  8392:3     RollingLog : LoadLocalPolicyInfo: load local machine

    10/17/2016 16:08:07 INFO  8392:3     RollingLog : LoadLocalPolicyInfo: load user

    10/17/2016 16:08:10 INFO  8392:4     RollingLog : Request: failed get target info.

    10/17/2016 16:08:10 INFO  8392:1     RollingLog : PolicySync: failed request

    10/17/2016 16:08:10 INFO  8392:1     RollingLog : Exit PolicySync.exe with code -3

     

    Info shown in Policysync.log:

    Mon, 17 Oct 2016 16:08:10 GetLdapInfo: ldapwhoami.exe failed - err=-2147463168

    Mon, 17 Oct 2016 16:08:10 GetLdapInfo: use cached logon info

    Mon, 17 Oct 2016 16:08:10 GetLdapInfo: not a valid ldapinfo, return E_FAIL

     

    Cause

    Open CMD window, run ldapwhoami.exe (located at C:\Program Files (x86)\LANDesk\LDClient)

    In the output, there are special characters in the OU name.

    In my case, the special character was '/'

    Note: There is no limitation for OU name in the domain controller, this is an unsupported character by Ivanti EPM.

     

    Resolution

    Change the OU name to not contain any special characters.