My Browser session seems to be caching web pages. How do I prevent this?

Version 1

    Verified Product Versions

    Wavelink Naurtech CETerm 5.7

    If you notice that your browser session with CETerm is not making a request to the Web server following a previous load of the same page, then it may be caching the page. This issue is related to the inability to disable caching in the Windows CE browser components. The Microsoft components ignore directives to "not cache" and some of the cache control features are "not implemented" according to Microsoft. Usually you can manually clear the cache from the Pocket IE control applet or CE .NET IE menu. CETerm uses the same cache so it will be cleared.

    Here are some notes on "dynamic" cache control techniques. Please note that the behavior can be different on Windows Mobile and Windows CE OS platforms. The "time value" technique (third suggestion) is the most robust if you are generating pages on the fly.

    • Try adding the following to your web page:
     <meta http-equiv="Pragma" content="no-cache"> and <meta http-equiv="Expires" content="0"> 
    • Follow this link to information on setting a registry key which should disable caching. Try setting "SyncMode5" to the value 3.

    http://msdn.microsoft.com/library/default.asp?url=/library/en-us/wceie55/html/coconInternetExplorer55RegistryKeys.asp

    • One trick that we recommend is to insert a value in the page that changes with every update and request. This won't work for your "home" URL but it may help for other pages in your application:
     <form name=myform method=GET action=...  > <input type=hidden name=time value="176000405"> </form> 

    where the time value can be obtained from "GetTickCount()" in some servers.