Session timeout in Internet Edition

Version 2
    Question

    IIS is not timing out, thus using up HelpDesk/SupportCenter Internet Edition licences.

    Answer

    For the below to work the HIE/SCIE Virtual directory MUST be set up as an application:

     

    Please see below the settings that need to be applied to your IIS in order

    to log out Analysts/End Users after a specified period of inactivity.  After

    making these changes you will need to stop and restart the IIS Service.

     

    Change Internet Information Server (IIS) setting:

    For IIS5

    1. Start>Settings>Control Panel

    2. IIS

    3. Expand Web Server by clicking on the +

    4. Right click the Default Web site and select Properties

    5. In the Connections section set Timeout to required period in seconds

     

    Also:-

     

    1. Start>Settings>Control Panel

    2. IIS

    3. Expand Web Server by clicking on the +

    4. Right Click the HelpDesk Virtual Directory and select Properties 5. Click

    on the Configuration button and select App Options 6. Under App Options

    change timeout as required.

     

    For IIS 4:

     

    1.Use the Microsoft Management Console and right click on the application

    (i.e. usually SupportCenter\HelpDesk or HIE) 2. Choose Properties 3. Press

    the Configuration Button 4. Choose Application Options 5. The Enable Session

    State check box should be ticked and below it should be the timeout value in

    minutes

     

    You can also check the timeout set for the web server itself by:-

     

    • Again inside Microsoft Management Console

    • Right Click Web Server name

    • Click on Edit

    • Select the 'Web Site' tab and check the details in the Connections

    section.

     

    For IIS3:

    1. Go into the registry

    HKEY_LOCAL_MACHINE\CurrentControlSet\Services\W3SVC\ASP\Parameters

    2. Change value of Session Timeout

     

     

    If after making the above changes does not produce the correct results then:

    Within IIS Manager, go to Application Pools

    Then go to the folder which has the Helpdesk application pool within it (it could be called something like DefaultAppPool).
    On this folder right click and go to properties.
    Then click on the performance tab.
    At the top, you will have an Idle timeout. If you can change this to the timeout period requested.

    Then carry out an IISReset.

     

    Environment

    HelpDesk/SupportCenter Internet Edition all versions