Problem / Solution: Workspaces shows a blank interface or returns "Internal Error: Forbidden"

Version 5

    Verified Product Versions

    Service Desk 7.8.xService Desk 2016.xAsset Manager 2016.x

    Requires Access To:

    • Configuration center
    • IIS console of the Workspaces and Framework server(s)


    Error message:

    When you try to log in Workspaces, you get: Internal Error: Forbidden

    Error message login.png

    Other symptoms:

    You managed to log in but you're facing a blank screen (no shortcut, no browsing bar at the top such as "Home")

    Workspaces blank.png


    Identified Cause:

    This might be caused by a mismatch between SSL settings in IIS and the configuration of Workspaces in Configuration Center.


    Solution / Workaround:

    If you force the SSL encryption on the Framework application (Cf picture a. below), go to the configuration center to ensure that the Workspaces application is set up to communicate with the Framework through HTTPS. (Cf. picture b. below)


    Picture a.

    IIS SSL Settings.png


    Picture b.

    Configuration Centre settings.png