Unable to Install Xtraction with Time and Currency Format set to different language than English

Version 5

    Description

     

    When trying to install Xtraction with Time and Currency Format set to different language than English, Xtraction installation fails at 'Installing Xtraction' step.

     

    Snap 2017-05-18 at 22.23.38.png

    Pic. 1. Setting Virtual Machine (Server) Operating System

     

    If you set your Virtual Machine (Server) Operating System as above:

     

    1.Language to install: English (United States)

    2. Time and currency format: German (Germany)

    3. Keyboard or input method: German

     

    then the Xtraction installation will fail at the 'Xtraction Installation' step. It looks like when you choose for instance 'German' for the Time and Currency Format, it chooses 1031 MST file (German) as the default language thus (other MST files are chosen in case of the different language set for Time and Currency Format), the installer tries to use this and it cannot as the default language should be English.

     

    In the Xtraction installation error log look for the last line which have the State: Failure:

     

    2017-05-03 09:30:44 INFO: Execution of IISConfiguration2012 completed. Return code: 0, State: Success (SetupController.ExecuteNextCommand())

    2017-05-03 09:30:44 INFO: Executing command XtractionInstallationDeu (SetupController.ExecuteNextCommand())

    2017-05-03 09:30:44 INFO: Executing: MsiExec.exe /i "C:\Users\Administrator\Desktop\Xtraction (2016.4.0111.01)\Xtraction\Xtraction\Xtraction.msi" /qn /lv+ "C:\ProgramData\LANDESK\Xtraction\Install\16.4\Log\LANDESK.Install.Xtraction.MSI.log" TRANSFORMS=1031.mst ENABLE_XTRACTION=1 REBOOT=ReallySuppress APPDIR="C:\Program Files (x86)\Xtraction Software\Xtraction" (Launcher.ExecuteXmlCommand())

    2017-05-03 09:30:48 ERROR: Execution of XtractionInstallationDeu completed. Return code: 1602, State: Failure (SetupController.ExecuteNextCommand())

     

    When running the last line of the Xtraction installation log file:

     

    MsiExec.exe /i "C:\Users\Administrator\Desktop\Xtraction (2016.4.0111.01)\Xtraction\Xtraction\Xtraction.msi" /qn /lv+ "C:\ProgramData\LANDESK\Xtraction\Install\16.4\Log\LANDESK.Install.Xtraction.MSI.log" TRANSFORMS=1031.mst ENABLE_XTRACTION=1 REBOOT=ReallySuppress APPDIR="C:\Program Files (x86)\Xtraction Software\Xtraction" without silent mode - /qn

     

    from the command line, the below error message shows (when German language is set for the Time and Currency Format):

     

    "An error occured while applying security settings. User is not a valid user or group. This could be a problem with package, or a problem connecting to a domain controller on the network. Check your network connection and click Retry, or cancel to end the Install" and the installation stops.

     

    Workaround

     

    To bypass the issue, please run the below line from command line:

     

    MsiExec.exe /i "C:\Users\Administrator\Desktop\Xtraction (2016.4.0111.01)\Xtraction\Xtraction\Xtraction.msi" /qn /lv+ "C:\ProgramData\LANDESK\Xtraction\Install\16.4\Log\LANDESK.Install.Xtraction.MSI.log" TRANSFORMS=1031.mst ENABLE_XTRACTION=1 REBOOT=ReallySuppress APPDIR="C:\Program Files (x86)\Xtraction Software\Xtraction"

     

    and instead: TRANSFORMS=1031.mst (German mst file) use TRANSFORMS=1033.mst (US mst file)

     

    The installation should be completed without any further errors.

     

    Please also check the article related to the issue with language pack:

     

    Unable to Install Xtraction on a Machine Configured With a Language Pack