検証バージョン
LANDESK Management Suite 2016.x
内容
UDD(非管理デバイス検出)/ XDD(拡張デバイス検出)によって検出されたデバイスから最初のスキャンデータがコアサーバに送信された時、コアサーバの Windows イベントビューワーに次のイベントが記録されます。
メッセージ:
LANDESK Inventory サーバ エラー 4100 データベース例外:xxxx.SCN, LDInv.dll
-2147217913
文字列から日付と時刻、またはそのいずれかへの変換中に、変換が失敗しました。
UPDATE COMPUTER SET AGLS_status = ?, AGLS_LastAttempted = ? WHERE Computer_Idn = ?, Thread ID: 14268。
原因
この問題の原因はスキャンファイルが computer テーブルの AGLS_status カラムと AGLS_LastAttempted カラムに null を追加しようとしたことです。これらのカラムのデータタイプでは null を格納することができません。
調査番号:433728
影響
これは表面的なエラーであり、スキャンファイルの処理に影響を及ぼさないため、無視することができます。
解決策
該当箇所は Ivanti Endpoint Manager バージョン2017.1で更新され、このメッセージは Windowsイベントビューワーに記録されなくなりました。最新バージョンでの利用をお勧めいたします。
英文ドキュメント: