GoldMine Web (GMWEB) 2017.1 and 2017.1.1  - An error has occurred on the server. Please contact your system administrator when clicking the Refine button for an Advanced Search 

Version 1

    Details

    GoldMine Web (GMWEB) 2017.1 and 2017.1.1  - An error has occurred on the server. Please contact your system administrator when clicking the Refine button for an Advanced Search 


    In GoldMine Web 2017.1. GA (GMConnect 2017.1.0.460) and also GoldMine Web 2017.1.1 (GMConnect 2017.1.0.483)
    1. Log into GMWEB
    2. CONTACTS page
    3. Click on the REFINE button
    >>   RESULT: Server Error
    An error has occurred on the server. Please contact your system administrator.



    Resolution

    [CAUSE]
    - This is logged as RM 253173
    - The root cause is that there is no Default Record Type defined within GoldMine or in case there is a Default Record Type defined the Default Record Type has no Primary view assigned.
     

    [RESOLUTION]
    This behavior is expected to be fixed in GoldMine 2017.1 HF2, please make sure to review the Release Notes once this version will be available

    [WORKAROUND]

    As there is currently no ETA available for GoldMine 2017.1 HF2, customers experiencing the behavior should define a default record type

    For any changes in the Record Type Admin Center it is recommended to make sure to have a full running backup of the GoldMine database!

    A. When there is not yet any Record Type defined


    1. Login with master rights
    2. Tools >> Configure >> Record Types
    3. Right Click on Record Types >> New Record Type
    4. Fill in any and appropriate information + Activate the check box Set as Default Record Type
    a. Record Type Name e.g. Test
    b.  Important I:  Primary Fields View e.g. Wide View
    c. Custom Screen e.g, End User Screen
    d. If desired select and adjust also Relationship Tree Section Names and a GM+View template
    e. Important II: Activate the check box Set as Default Record Type


    6. OK
    7. Switch to a different area e.g. Primary Views >> this makes that button Apply changes active
    8. Apply changes Icon


    9. Perform an IISreset
    10. Verify the behavior again

    >> RESULT: The Refine button should now work



    B. When there are Record Types defined, but no Default Record Type


    1. Login with master rights
    2. Tools >> Configure >> Record Types
    3. Expand the list of Record Types
    4. Highlight any of the record types (the desired default one) >> Right Click >> Edit
    5.a. Important I:  Primary Fields View e.g. Wide View
    5.b. Important II: Activate the check box Set as Default Record Type


    6. OK
    7. Switch to a different Record Type >> this makes the Apply changes icon active
    8. Apply changes Icon
    9. Technically it should not be necessary but perform an IISreset
    10. Verify the behavior again

    >> RESULT: The Refine button should now work



    C. When there is a Default Record Type defined, but no Primary View assigned to the Default Record Type



    1. Login with master rights
    2. Tools >> Configure >> Record Types
    3. Expand the list of Record Types
    4. Highlight the Default Record Type >> Right Click >> Edit
    5. Important: Select the desired Primary Fields View for the Record Type e.g. Wide View


    6. OK
    7. Switch to a different record Type >> this makes the Apply changes icon active
    8. Apply changes Icon
    9. Technically it should not be necessary but perform an IISreset
    10. Verify the behavior again

    >> RESULT: The Refine button should now work



    If the same error message is still presented, please verify related Knowledge Article # 24322